You need to update Flash 5 player, press here
If you are 100% sure that flash 5 player is installed press here